在Debian编译lighttpd-1.4.19过程出现的错误处理

在Debian4自带安装的是lighttpd-1.4.13, 但在lighttpd网页看见了lighttpd-1.4.19稳定版当然用新的,于是自己下载下来自己编译,但都几多编译错误,先把这些编译过程出现的错误和处理方法记录下来,留待以后再遇到时作资料查询。

出现configure: error: C compiler cannot create executables … 安装apt-get install libc6-dev.

出现configure: error: configure: error: pcre-config not found … 安装apt-get install libpcre3-dev

出现configure: error: zlib-headers and/or libs where not found … 安装apt-get install zlib1g-dev

出现configure: error: bzip2-headers and/or libs where not found … 安装apt-get install libbz2-dev

还有新装的 Debian 时是没有安装 make 的, 所以都要 => apt-get install make

关于无聊人

一个无聊人而已
此条目发表在lighttpd分类目录,贴了, , , , 标签。将固定链接加入收藏夹。

发表评论

电子邮件地址不会被公开。 必填项已用*标注